WordPress 3 et 1&1 : le coup de l’erreur 500

Vous avez voulu faire le grand malin et installer WordPress 3 sur 1&1 et … HOP une belle erreur 500 sur l’interface d’administration (le wp-admin) ? Normal.

Tout d’abord à titre personnel je vous déconseille 1&1 mais ça c’est autre chose. Ensuite… normalement votre problème est assez facile à résoudre et il est probablement lié à votre fichier .htaccess et au paramétrage étrange des serveurs mutualisés 1&1. Si la solution ci-dessous ne solutionne pas votre problème, jetez aussi un oeil à celle-ci.

Donc donc donc vous allez devoir modifier votre fichier .htaccess c’est assez facile surtout sous Linux et Mac OS, parfois un peu plus dur car Windows ne les affiche pas toujours.

1) Lancez votre cher client FTP (ou si vous êtes un homme qui aime le SSH, faites le en SSH.. bref)
2) Allez chercher le fichier .htaccess à la racine de votre blog et ouvrez de quoi l’éditer
3) Repérez les choses suivantes :

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress

Et modifiez en :

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
AddType x-mapp-php5 .php
AddHandler x-mapp-php5 .php
# END WordPress

Après ça devrait marcher ;-)

Tags:

  • Thibz

    Merci pour le conseil très utile, car l’erreur 500 à la connexion c’est pas cool…
    C’est vrai que 1&1 me déçoit de plus en plus…

  • Zac

    Très utile en effet, ça m’a bien dépanné (je suis pas chez 1&1 mais une amie a pris un hébergement chez eux …

    Petite note, si vous ne trouvez pas le fichier .htaccess, il faut le créer !!!

    Pour les possesseurs de Windows, vous n’arriverez pas à le créer sur votre PC.

    Créez le fichier htaccess.txt, remplissez le avec le contenu qui est au dessus, sauvez le et téléchargez le sur votre site (à la racine du blog) et renommez-le directement avec le logiciel de FTP en .htaccess

    Et oh miracle, ça fonctionne :D

    Merci pour ce super truc !

  • Je ne l’avais pas ce fichier, je l’ai crée sur tes conseils mais ça ne fonctionne toujours pas.
    HELP…

  • Silvia

    Bon ben ça n’a pas marché pour moi…
    J’ai eu un semblant d’espoir quand j’ai pu finaliser l’install, puis me logger, et puis non, 500 is back. J’ai changé le chmod du fichier en 444, mais rien n’y a fait.

  • Silvia

    EDIT ! EDIT !
    Après y avoir passé ma journée, j’ai enfin réussi. Je crois avoir trouvé la marche à suivre, dans l’ordre :
    – Installer wordpress
    – ajouter le fichier htaccess.txt puis le renommer (ne pas essayer de l’ajouter en .htaccess directement)
    – changer le chmod en 444 sans rien trifouiller d’autre
    – boire un verre
    – lancer

    J’ai l’impression en fait que si on a essayé de faire quoi que ce soit qui n’entre pas strictement dans cet agenda (comme essayer de lancer wordpress une première fois sans l’astuce .htaccess), ça foire… ?

  • Pingback: Léo Gatellier – Blog » Blog Archive » Wordpress3 + 1and1 = Erreur 500()

  • Gerald

    Bonjour et Merci à toi,
    ça fonctionne, j’suis bien content après des heures de galère, puré je crois que 1&1 c’est pas la solution….lol
    et merci encore ! !!!

  • De rien :)

  • Aurélia

    Merci !!!!!!!!!!!!!!!!!!!!!!
    Je galérais depuis des semaines, j’avais déjà vu cette astuce, sous plusieurs formes, je l’ai essayé plusieurs fois, mais c’est celle là qui a marché !
    PS : je suis sur mac :
    il faut créer un nouveau doc avec textedit
    écrire ce qu’il y a plus haut
    le mettre au format texte (sans style)
    l’enregistrer sous un nom quelconque
    L’uploader sur le FTP et le renommer en « .htaccess »
    Enfin, :)
    C’est cool

  • EmilieB

    Merci !

  • Lucien Dubois

    Une autre solution ici: http://error5001and1.luciendubois.net

  • Darknote

    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .phpc’est 2 lignes servent à passer sous PHP5,c’est obligatoire depuis WordPress 2.8,il y a un sujet épinglé sur le forum de wordpress-fr.net à ce sujet.Maintenant on peut passer par l’espace client chez 1&1 pour choisir sa version de PHP,plus besoin de ces 2 lignes.

  • Jules Nziet

    Pareil pour moi :(

  • frida

    Bravo, bravo, bravo pour ce tuto!!!
    Après des journées de galères wordpress est enfin installé et fonctionne!!!!!!!!

    Mille mercis!!!

  • Romain

    Un grand merci à toi ! Ça fonctionne nickel chrome !